import Foundation
let pattern = #"(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)