use strict;
my $str = 'http://www.example.com/g/1337/Game-Title
example.com/g/1337/Game-Title
http://example.com/g/1337/Game-Title
www.example.com/g/1337/Game-Title';
my $regex = qr/(?:http:\/\/)?(?:www\.)?example\.com\/g\/(\d+)\/\w/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";