# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bthis\b(?![^{]*\})/replacement/gs;t' <<< "$(this).find('option').each(function() {
$(this).hide();
})"