#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\bthis\b(?![^{]*\})"
Local $sString = "$(this).find('option').each(function() {" & @CRLF & _
"" & @CRLF & _
" $(this).hide();" & @CRLF & _
"})"
Local $sSubst = "replacement"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)