re = /\bthis\b(?![^{]*\})/
str = '$(this).find(\'option\').each(function() {
$(this).hide();
})'
subst = 'replacement'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result