import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bthis\\b(?![^\\{]*\\})";
final String string = "$(this).find('option').each(function() {\n\n"
+ " $(this).hide();\n"
+ "})";
final String subst = "replacement";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}