use strict;
my $str = '$(this).find(\'option\').each(function() {
$(this).hide();
})';
my $regex = qr/\bthis\b(?![^{]*\})/sp;
my $subst = 'replacement';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";