using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bthis\b(?![^{]*\})";
string substitution = @"replacement";
string input = @"$(this).find('option').each(function() {
$(this).hide();
})";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}