$re = '/\bthis\b(?![^{]*\})/s';
$str = '$(this).find(\'option\').each(function() {
$(this).hide();
})';
$subst = "replacement";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;