const regex = /\bthis\b(?![^{]*\})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bthis\\b(?![^{]*\\})', 'gs')
const str = `\$(this).find('option').each(function() {
\$(this).hide();
})`;
const subst = `replacement`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);