import Foundation
let pattern = #"\bthis\b(?![^{]*\})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
$(this).find('option').each(function() {
$(this).hide();
})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replacement"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)