#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]"
Local $sString = "$_GET['banner_name']" & @CRLF & _
"$_GET[banner_name]" & @CRLF & _
"$_POST['banner_name']" & @CRLF & _
"$_POST[banner_name]" & @CRLF & _
"$_SESSION['banner_name']" & @CRLF & _
"$_SESSION[banner_name]" & @CRLF & _
""
Local $sSubst = "$$1['$2']"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)