const regex = /\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(_POST|_SESSION|_GET)\\[([^\\\'][0-9a-zA-Z _]+?[^\\\'])\\]', 'gmi')
const str = `\$_GET['banner_name']
\$_GET[banner_name]
\$_POST['banner_name']
\$_POST[banner_name]
\$_SESSION['banner_name']
\$_SESSION[banner_name]
`;
const subst = `$$1['$2']`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);