$re = '/\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]/mi';
$str = '$_GET[\'banner_name\']
$_GET[banner_name]
$_POST[\'banner_name\']
$_POST[banner_name]
$_SESSION[\'banner_name\']
$_SESSION[banner_name]
';
$subst = "$$1['$2']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;