using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]";
string substitution = @"$$1['$2']";
string input = @"$_GET['banner_name']
$_GET[banner_name]
$_POST['banner_name']
$_POST[banner_name]
$_SESSION['banner_name']
$_SESSION[banner_name]
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}