import Foundation
let pattern = #"\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
$_GET['banner_name']
$_GET[banner_name]
$_POST['banner_name']
$_POST[banner_name]
$_SESSION['banner_name']
$_SESSION[banner_name]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$$1['$2']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)