// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]").unwrap();
let string = "$_GET['banner_name']
$_GET[banner_name]
$_POST['banner_name']
$_POST[banner_name]
$_SESSION['banner_name']
$_SESSION[banner_name]
";
let substitution = "$$1['$2']";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}