use strict;
my $str = '$_GET[\'banner_name\']
$_GET[banner_name]
$_POST[\'banner_name\']
$_POST[banner_name]
$_SESSION[\'banner_name\']
$_SESSION[banner_name]
';
my $regex = qr/\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]/mip;
my $subst = '$$1[\'$2\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";