re = /\$(_POST|_SESSION|_GET)\[([^\'][0-9a-zA-Z _]+?[^\'])\]/mi
str = '$_GET[\'banner_name\']
$_GET[banner_name]
$_POST[\'banner_name\']
$_POST[banner_name]
$_SESSION[\'banner_name\']
$_SESSION[banner_name]
'
subst = '$$1[\'$2\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result