#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "src=(['"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)"
Local $sString = "<iframe width="425" height="349" src="http://www.youtube.com/embed/8tPnX7OPo0Q" frameborder="0" allowfullscreen></iframe>"
Local $sSubst = "src=\1\2?wmode=transparent"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)