re = /src=(['"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)/
str = '<iframe width="425" height="349" src="http://www.youtube.com/embed/8tPnX7OPo0Q" frameborder="0" allowfullscreen></iframe>'
subst = 'src=\\1\\2?wmode=transparent'
result = str.sub(re, subst)
# Print the result of the substitution
puts result