const regex = /src=(['"])(https?:\/\/[^ >]*?youtu\.?be[^ >]+?)(?=\1)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src=([\'"])(https?:\\\/\\\/[^ >]*?youtu\\.?be[^ >]+?)(?=\\1)', '')
const str = `<iframe width="425" height="349" src="http://www.youtube.com/embed/8tPnX7OPo0Q" frameborder="0" allowfullscreen></iframe>`;
const subst = `src=\1\2?wmode=transparent`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);