import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=(['\"])(https?:\\/\\/[^ >]*?youtu\\.?be[^ >]+?)(?=\\1)";
final String string = "<iframe width=\"425\" height=\"349\" src=\"http://www.youtube.com/embed/8tPnX7OPo0Q\" frameborder=\"0\" allowfullscreen></iframe>";
final String subst = "src=\\1\\2?wmode=transparent";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}