# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ ]+//gm;t' <<< "123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789"