re = /[ ]+/m
str = '123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result