use strict;
my $str = '123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789';
my $regex = qr/[ ]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";