#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[ ]+"
Local $sString = "123456789" & @CRLF & _
" 12 345 6789" & @CRLF & _
"123456789" & @CRLF & _
" 12 345 6789" & @CRLF & _
" 0 12 345 6789" & @CRLF & _
"0123456789" & @CRLF & _
"012 345 6789" & @CRLF & _
"0123456789"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)