using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ ]+";
string substitution = @"";
string input = @"123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}