package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ ]+`)
var str = `123456789
12 345 6789
123456789
12 345 6789
0 12 345 6789
0123456789
012 345 6789
0123456789`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}