# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(cat)/<em>$1<\/em>/ig;t' <<< "\"I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association.\"
"