# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(cat)"
test_str = ("\"I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association.\"\n")
subst = "<em>$1</em>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.