package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(cat)`)
var str = `"I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association."
`
var substitution = "<em>$1</em>"
fmt.Println(re.ReplaceAllString(str, substitution))
}