using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(cat)";
string substitution = @"<em>$1</em>";
string input = @"""I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association.""
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}