use strict;
my $str = '"I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association."
';
my $regex = qr/(cat)/ip;
my $subst = '<em>$1</em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";