import Foundation
let pattern = #"(cat)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
"I like to play with cats, as does Cathy, who is a member of ACATA, which is the American Cat And Tiger Association."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<em>$1</em>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)