#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?"
Local $sString = "<a href='http://www.test.com'>http://www.test.com</a>" & @CRLF & _
"" & @CRLF & _
"http://www.test.com" & @CRLF & _
"" & @CRLF & _
"http://www.test.com/example" & @CRLF & _
"" & @CRLF & _
"http://www.test.com" & @CRLF & _
"" & @CRLF & _
"<a href='http://www.test.com'>http://www.test.com</a>" & @CRLF & _
"" & @CRLF & _
"<a href='http://www.test.com'>http://www.test.com</a>" & @CRLF & _
"" & @CRLF & _
"http://www.test.com/example/two" & @CRLF & _
"" & @CRLF & _
"<a href='http://www.test.com'>http://www.test.com</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")