package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?`)
var str = `<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href='http://www.test.com'>http://www.test.com</a>
<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com/example/two
<a href='http://www.test.com'>http://www.test.com</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}