$re = '/.+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?/i';
$str = '<a href=\'http://www.test.com\'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href=\'http://www.test.com\'>http://www.test.com</a>
<a href=\'http://www.test.com\'>http://www.test.com</a>
http://www.test.com/example/two
<a href=\'http://www.test.com\'>http://www.test.com</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);