import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+((www\\.|(http|https|ftp|news|file)+\\:\\/\\/)[_.a-z0-9-]+\\.[a-z0-9\\/_:@=.+?,##%&~-]*[^.|\\'|\\\\||\\# |!|\\(|?|\\[|,| |>|<|;|\\)])(.+)?";
final String string = "<a href='http://www.test.com'>http://www.test.com</a>\n\n"
+ "http://www.test.com\n\n"
+ "http://www.test.com/example\n\n"
+ "http://www.test.com\n\n"
+ "<a href='http://www.test.com'>http://www.test.com</a>\n\n"
+ "<a href='http://www.test.com'>http://www.test.com</a>\n\n"
+ "http://www.test.com/example/two\n\n"
+ "<a href='http://www.test.com'>http://www.test.com</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}