use strict;
my $str = '<a href=\'http://www.test.com\'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href=\'http://www.test.com\'>http://www.test.com</a>
<a href=\'http://www.test.com\'>http://www.test.com</a>
http://www.test.com/example/two
<a href=\'http://www.test.com\'>http://www.test.com</a>';
my $regex = qr/.+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}