const regex = /.+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+((www\\.|(http|https|ftp|news|file)+\\:\\\/\\\/)[_.a-z0-9-]+\\.[a-z0-9\\\/_:@=.+?,##%&~-]*[^.|\\\'|\\\\||\\# |!|\\(|?|\\[|,| |>|<|;|\\)])(.+)?', 'gi')
const str = `<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href='http://www.test.com'>http://www.test.com</a>
<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com/example/two
<a href='http://www.test.com'>http://www.test.com</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}