import re
regex = re.compile(r".+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?", flags=re.IGNORECASE)
test_str = ("<a href='http://www.test.com'>http://www.test.com</a>\n\n"
"http://www.test.com\n\n"
"http://www.test.com/example\n\n"
"http://www.test.com\n\n"
"<a href='http://www.test.com'>http://www.test.com</a>\n\n"
"<a href='http://www.test.com'>http://www.test.com</a>\n\n"
"http://www.test.com/example/two\n\n"
"<a href='http://www.test.com'>http://www.test.com</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")