using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?";
string input = @"<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href='http://www.test.com'>http://www.test.com</a>
<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com/example/two
<a href='http://www.test.com'>http://www.test.com</a>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}