// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i).+((www\.|(http|https|ftp|news|file)+\:\/\/)[_.a-z0-9-]+\.[a-z0-9\/_:@=.+?,##%&~-]*[^.|\'|\\||\# |!|\(|?|\[|,| |>|<|;|\)])(.+)?").unwrap();
let string = "<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com
http://www.test.com/example
http://www.test.com
<a href='http://www.test.com'>http://www.test.com</a>
<a href='http://www.test.com'>http://www.test.com</a>
http://www.test.com/example/two
<a href='http://www.test.com'>http://www.test.com</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}