package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^)]*\)(*SKIP)(*F)|\|`)
var str = `999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}