$re = '/\([^)]*\)(*SKIP)(*F)|\|/';
$str = '999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);