re = /\([^)]*\)(*SKIP)(*F)|\|/
str = '999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end