import re
regex = re.compile(r"\([^)]*\)(*SKIP)(*F)|\|")
test_str = "999|150|222|(123|145)|456|(123|123|123)|12,260|(10|10000(100|1110000))|111111"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")