# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#define (Facility\w*)\s+%%%\s+(\w+)\s+\d+/z$1 = $2,/g;t' <<< "#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53
#define FACILITY_USERMODE_HYPERVISOR tty"