import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#define (Facility\\w*)\\s+%%%\\s+(\\w+)\\s+\\d+";
final String string = "#define FacilityUsermodeHypervisor %%% FACILITY_USERMODE_HYPERVISOR 53\n"
+ "#define FACILITY_USERMODE_HYPERVISOR tty";
final String subst = "z$1 = $2,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}